Laser investigation last night

After a few queries and questions, had a long look at the laser last night with Matt C

I used a known job, (one i’ve run 10 or 15 times) as the standard and cut 3mm Acrylic from a sheet i’ve had in the car for weeks so lots of known knowns. The job is a mixed bitmap engrave and vector cut.

The first point to note is that no-one should have to be messing with the print settings for the laser, if there’s an issue its probably Not these settings. please leave them as you find them or as per the instructions on Laser Cutter - Trotec Speedy 300


Next, once we got it cutting (see next section for that joyful couple of hours or pain) it seemed to work well with the engraving being good and clean and the edges smooth. I didn’t see excessive smoke and what smoke I saw got extracted at a reasonable rate.
The lens and mirror also looked fine as did the extract vents at the back of the machine.

On to the issues.
Inkscape appears to be fundamentally broken and I ‘think’ we know why.
When we were sending a mixed mode job to the laser from Inkscape, it would not recognise the vector cut, only the engrave. this, as above, is a job that has worked previously loads of times.

We tried all sorts of settings and played with Inkscape but every combination appeared to send the vector (lines) as messy bitmaps. This is obvious by changing the Materials setting in the Trotec software from cut to engrave. in cut you get 0.00 no matter what you do but switch to engrave and you get 200.00 secs or some other daft number. the driver is not seeing/receiving the vector and it appears as a corrupt bitmap. Illustrator sends fine.

After a lot of playing and with Matt Goggling, it appear that Inkscape have changed the vector handling in the later versions and our theory is that the Trotec can’t understand this new format when sending multi mode jobs.

By way of a check, we fired up the job in Inkscape, ungrouped everything so each element was separately editable and then Copy/Pasted the job to Adobe illustrator.
From here, you can adjust each element (so we know Illustrator has understood the job) and if you Print, the job works fine on the Trotec with both Engrave and Vector cut working as designed.

Looking on the web, as above, Inkscape appears to have changed the handling of vectors (lots of complaints)
Unfortunately, the Inkscape download site was off line last night so we couldn’t test this further.

I think the next stage of testing would be to completely remove Inkscape from the laser pc and download/install the last known good version 0.92 - if we’re right, this version should work with the Trotec driver as previous.

This is an ongoing investigation but I think were getting close to the source of some of the issues. be good if we can use this thread to complete the investigation.

i’m not about this weekend, @lasertechs / members, can someone have a look at downgrading the software ?



I have bought this issue quiet a few times.

I believe this issue was left with @Jonathan and @unknowndomain who had agreed to look at this together once Jonathan was back from holiday.

I mean the issue is Inkscape, and there is no fix right now from the sounds of it, what we did agree to do was rebuild the laser computer, but that won’t fix this problem.

[quote=“Courty, post:1, topic:11326”]
I think the next stage of testing would be to completely remove Inkscape from the laser pc and download/install the last known good version 0.92 - if we’re right, this version should work with the Trotec driver as previous.
[/quote] ??



this issue is not only happening in inkscpape. It is also happening in illustrator.

Any ideas what could be a solution?

I believe the issues for Inkscape and Illustrator are different. As I wrote elsewhere on here, I had the same issues with the installed version of Inkscape and the copy&paste to Illustrator trick is working just fine for me. However, there might be other issues with Illustrator too that I haven’t run into. (Happy to have another look over this with you @StudioNelle)

1 Like

@directors @lasertechs My suggestion is that we buy a compatible 250GB SSD drive to reinstall Windows 10 on and also ask Trotec for the latest Job Control.

From there we can do a fresh install and build from scratch to hopefully resolve any issues, and start a fresh.

1 Like

Based on the content of the thread - a PC rebuild sounds like a lot of work for a non guaranteed fix. Just an idea - would it be possible to install Job Control on an alternative machine to rule out the Trotec and confirm the existence of ghosts in the machine?

Happy to help where I can - watching progress bars on my computer used to be a hobby :wink:

1 Like

There’s a PC under the main table in the Clean Room, and the Job Control CD should? be in the laser cleaning kit box

Although this needs to stay coordinated…so we don’t lose track of what we’re trying to solve. So I’d suggest checking with @Jonathan might be a useful tool for this machine… On the basis that any files stored on there should be considered Ephemeral

This is what I’ve been banging on about too!

If they are to be considered ephemeral (yes I had to look it up!)

Let me know (and others ) before they are erased as there are files there saved in a folder in my name that I use regularly both for the workshop jigs etc and for the vapes I make.

usually, in this sort of setup, you’d put some kind of additional mass storage to hold this kind of thing, that wouldn’t get wiped on reboot - could be as simple as a USB stick or something.

@Jonathan - i’m in the space and ill install the drivers on the clean room PC as a pre experiment but will not connect it etc, just consider it ready till you say go.


Status of 'set up another PC as a trotec ready device for testing’ project:

PC in clean space:

  • JobControl requires a licence - it is not clear to me if the licence is controlled and I did not want to jeopardise the main install - INSTALLATION NOT COMPLETED AS RESULT
  • Inkscape 0.91 is on it
  • requires illustrator licence

So sorry to have achieved nothing :wink:
FYI - I was in the space and was sitting next to the PC so no frustration has been felt or time wasted.

Hi, I’m in the space now doing some laser cutting and to my surprise it’s working straight from inkscape! Has someone fixed it or does this just add to the confusion? Thanks for all your investigations, really appreciate the work that goes into keeping things working!

1 Like

The license is restricted but I am sure they don’t mind people installing onto two machines for the purpose of testing/fixing things, I’ve done this myself in the past about 3 years ago.

I played about with it a few days ago. It worked for me too, I redownloaded Inkscape. Wasn’t sure if it was a fix so didn’t announce it.


I’ve asked Trotec about an updated JC licence and they’ve replied that there’s a free version out soon – and they’ll update us when it’s ready