Vinyl Cutter I've never used it

hi, I’ll be in the space tomorrow (Mon) early afternoon. If anyone’s around that knows about the Vinyl Cutter that can have a quick chat to me about it, that’d be great. If not, never mind!!! :wave:t5:

If noone shows up, there’s a nice tutorial in the tools page!


I tried once and gave up. I still don’t get how it works with backing stuff and application film…

1 Like

The goal is to cut the corners cleanly through the base material but not the backing. You can dial in the pressure with the cutter interface. I would recommend the web ui over connecting directly. A few test cuts usually help.


I should be in so long as nothing pops up with work


I didn’t even know it had a web interface, I thought you had to do something weird with drivers to even connect to it.

Back in February I popped a pi zero of mine in there and wrote a web interface. Shout out to @ovf for the network config. The tool page explains how to use it via browser.


Okay, a mere five months later I’m in and trying to use the vinyl cutter. I can only get it to absolutely mangle vinyl, it seems to be cutting every connecting line without lifting the cutter head when trying to trace out text spat out of illustrator and converted to an hpgl (or rather a plt but I think this is the same thing?) and just mashing itself.

The helpfully linked instruction pdf on the tool page now is a dead link (surprise) on the site and I can’t find the model of this cutter to look for it somewhere else.

Any tips or anyone with a better understanding of this machine who could advise?

Can you send a photo of the cutting piece? Sounds like it might not be positioned correctly and the blade isn’t lifting high enough.

I’ve used it a couple of times and haven’t seen it do that.

Poked out and at rest:

Sorry, can you send a pic of it mounted in the machine?

Mounted and homed.

That all looks good to me, so I don’t really have any suggestions other then trying with a much lower force setting. Sorry, I just wanted to see if it looked to be mounted correctly and it does found the manual, updated the tool page

1 Like

I wonder if it’s something to do with how the files are being generated to some degree? The lines might just be due to it not getting a command to lift the blade up at all.

One thing I can’t seem to find is what the test pattern is supposed to look like, to compare what it was doing with what it actually cut.

I also thing the test bit of vinyl I used might just not be flat enough to work.

based on your picture, Im thinking its that its not issuing the command to lift the cutter. I know that the hgpl file i was getting from inkscape was working, so maybe try that?

open your file in a text editor - are there any PD or PU commands in it?

1 Like

Well I just tried a new method, using a command line tool to generate the hpgl but now the little raspberry pi doesn’t seem to be responding on the network. I think I’m just cursed.

Or rather than cursed, does it mean the raspberry pi is corrupted somehow?

I’ll take a look when I’m back in country if no one else beats me to it. Otherwise, you can unplug the protruding usb cable and go the old-school route with drivers and serial. There are instructions on the tool pages but I have only done the Linux ones.

It’s been something like four years since I started thinking about using it, I’m very much not in a hurry…

1 Like

Looks like the 5V power supply blew. Externally powered, the pi boots and is accessible via

I’ll leave the pi taped to the stand for now. It can be powered by a phone charger and plugged into the USB B port on the cutter or the tool page driver directions should still work.