Trotec software doesn't recognize cut line


(Andrea Campanella) #1

I’m trying to cut something on the laser cutter but for some reason the cut time of the job is always 0 , I tried illustrator and inkscape with different profiles and files, no success,did anyone experienced any problems?


(Mike Kelly) #2

Yes, I’ve had this in inkscape, and also when opening an inkscape SVG in illustrator. I think files created in illustrator, or files imported into illustrator from other software packages should be OK.
As usual make sure you have your colours right, line thickness correct and opacity at 100%.


(Petra) #3

We fixed it.


(Alexander Baxevanis) #4

I’ve also found this to be rather temperamental. If anyone’s found a good way to fix it, or at least a few things to try, please put them here so we can start a list!


(Chanelle) #5

I had the same issue with a file I created and cut the day before, my resolution was to change colour from blue to red, ungroup all objects this allowed me to adjust all lines to 0.001in and cut via illustrator better than the previous day.

I am going to create a troubleshooting log, something we discussed a couple of years ago but it never got off the ground. If you come across any job control issues that you manage to resolve drop me a message and I will try to start troubleshooting a workbook for people to use when they get stuck.

Cheers


(Andrea Campanella) #6

I 'm still not convinced that is Inkscape’s fault.

The version installed is the same I did installed 3 months ago, I think something changed in the Trotec software settings…,

It is, in my opinion, important that we can still use inkscape and/or opensource software.


(Andrea Campanella) #7

Perhaps nuke the disk and reinstall? is it been done recenly , @lasertechs ?


(Louis) #8

Let’s not “nuke” anything… there has never been an issue I have not managed to resolve after some investigation… remember trotec has paid developers working to insure their software is robust and thats not something I can gaurentee from Inkscape… what’s the urgency on this project? Happy to help when available.(Lasertechs also have lives… :wink:)


(Paul Court) #9

One of the other issues we’ve mentioned before is Inkscape SVGs opened in Adobe can leave a white background behind each layer that the Trotec takes as a Bitmap not a vector.
If in Adobe you go to layers and ungroup, delete all the white backgrounds + do what @StudioNelle was talking about with the colours and lines, you can get the drawings to migrate and cut successfully. if not it treats everything as a Bitmap / engraving

Courty


(Dermot Jones) #10

Is the suggested workaround to open files with Illustrator at the moment?

If we can identify the issues we can reach out to both Inkscape and Trotec on this

IIRC Illustrator doesn’t handle SVG natively? So there may well be import issues when opening them, but the extra layers??? What a PITA

Every other Maker/Hackspace uses Inkscape…but none of them have a Trotec… however the knowledge is deep out there!


(Petra) #11

the fix yesterday took me 2minutes and all it took was copying and pasting from inkscape to illustrator and checking if the size is still the same - which was off by 1mm - and then scaling back. Which is all one has to do as far as I’ve experienced.

If there’s always Illustrator where we can open it we are cool.


(Andrea Campanella) #12

I just asked if we recently reinstalled Windows, last time I heard about it someone was saying that was due.

And yes, clearly paid developers are way better then people who work on opensource project like Inkscape or Linux :stuck_out_tongue:

Lasertechs have lives and deserve their time, I didn’t force anyone to answer.


(Andrea Campanella) #13

I agree with you , can be easily fixable.

I was just trying to investigate why this is happening, purely from a engineering point of view


(Petra) #15

Sure. Personaly I’d also love to see Inkscape working with JobControl directly.


(Louis) #16

I answer because I like to help, was just explaining it may not be right away… do you have a file that I can investigate?


(Andrea Campanella) #17

Thank you for your help, this is the file if someone is interested.

cut