Linking my Discourse account to my members account to booking inductions

Hey, I tried linking my account to my members account a while back but it did not work. I believe Dermot then did it manually but unfortunately it still does not show me the inductions section and appears to still be unlinked.

Anything you can do to help?

@directors if your Discourse installation was updated and the APIs have changed it’s like that the syncing code is also broken, this has happened before and it actually wasn’t that difficult to fix, if you are planning to keep using the membership system myself and @naxxfish developed let me know and I can try to find some time to make it work again.

1 Like

All sorted!

Great it worked. Thank you.

Ditto. I’m a bit rusty, but happy to help

Chaps, I cannot link my discourse username to my account either. Anything I’m doing wrong?

I’ve done some research into this using Discourse 2.4.0.beta5 and there were no issues, I did find a bug that would cause the membership system to crash during the linking process which is now fixed and I will push that commit up, although not sure what the situation is with @systems these days if Jonathan wanted he could update to fix that.

I am going to move on to looking at the discourse service which basically is the code which syncronises groups of members, however I am suspecting there might not actually be an issue with the membership system but that Discourse has gone extremely wonky.

Would be nice to hear from the @directors about this as this has been an issue for some time and I am happy to help but I guess we need an answer.

Further to this last message I have performed >50 security updates but there seems to be no issue with the membership system, the issue seems to lie with Discourse, it’s possible the issue is that the API key was changed at some point but really this needs @tomnewsom to have a look at why Discourse is being weird in general.

The pull request is here for @systems if they’re interested, it should be a case of:

  1. Shut down the system probably using either:
    a. pm2 ls then pm2 stop _ for each of the processes, then sudo shutdown now
    b. forever stop all or similar then sudo shutdown now
  2. Make a backup of the live system.
  3. Now we need to check if Node is installed using NVM or Node Source by seeing if which nvm returns a location or an error, if nvm is installed then nvm install 10, then confirm with node -v
  4. Else install node v10 using these instructions: https://github.com/nodesource/distributions
  5. Also worth doing a general distribution upgrade at this point too as it’ll be on 16.x LTS.
  6. Once thats all done navigate to wherever the membership system is stored and run git pull.
  7. Now npm install to get the package updates
  8. Give it a reboot and hope that everything just happens to come back up.
  9. Have a check through things like signup and login are working but then you should be good to go, with >50 less security vulnerabilities than before.
1 Like

The API key for the Makerspace account currently ends with a24f1
If that hasn’t changed, I might have to get my head back in the game and remember how to poke Discourse from the command line…

1 Like

I believe only @jonathanjo and yourself have membership system access so we’re still dependent on checking what is on the config file for that.

I think you mean @jonathanjo

Many apologies, indeed I do.

this matches the key on the membership config afaik. (looking at it now).

I’ll do all this business, as soon as I can work out how to accept the pull request.

In general, the vast majority of things seem to be behaving re linking to discourse, it appears only that the ‘link your account’ function is a bit bust. Looking to see if there has been an API change.

ok, minor change to the API. Required the API user to be re-set and removed the limit argument from the JSON call. Seems to be behaving again. but time will tell. As and when I can become a member of the Github org, I will submit a pull for the very minor change made, and also add Tommels changes.

P

2 Likes

I look forward to seeing what weird glitch it was.