Lasercutter pc acting up again


(Andrea Campanella) #1

I tried to print an svg from internet explorer (which have svg support) , supposedly, not being Inkscape should be able to send a valid svg to the laser cutter.

Basically nothing but illustrator can’t send a valid file to the laser cutter, plus, the “favourite” section of the trotec driver is crashing Windows.


(Duck) #2

This appears to have been an issue with the document size being set wrong, now seems to be working ok!


(Duck) #3

hmm, no spoke too soon.
As Andrea said it seems like only Illustrator will open into Job control in a way it will cut, and that will only cut a portion of my doc. User error is possible, but something odd seems to be happening…


(Louis) #4

Try defining the size yourself with a value that is closer to the size of your project. Sometimes when you select take from application it can be a little temperamental. This sometimes occurs if you have a very small bit of geometry.


(Duck) #5

Thanks - I did try changing it to A4, which should be correct, everything looked good in illustrator, except a dotted line marking part of the sheet. When transferred to job control only the Portion Of the image inside that line showed. I tried a few things, but that was the beat result I got - fortunately the job was six small items, and four showed correctly so I duplicated the job and managed to get eight cut instead.

I’m Sure there is a simple solution but could not work out what it was!


(Andrea Campanella) #6

@lasers, does anyone have a recent svg file they managed to cut? can you send me a copy of it? thanks.


(Chanelle) #7


(Chanelle) #8

I’m not sure if that is visible. But I made sure the lines are correct thickness 0.001 in or 0.0025mm (it will convert to 0.021 in illustrator). The lines initially didn’t cut, so I changed the colour from blue to red, made sure everything was un-grouped and it seemed to work ok except the cutting time was much longer than expected. I re-cut the same file the following day and the time reduced by about 10mins no changes to file just reopened and cut. The was no double cutting, and not the first time that I’ve seen the laser do that, I just put it down to it weird quirks.

Hope you manage to get it to work.


(Andrea Campanella) #9

But, it’s this engraved?


(Chanelle) #10

no it’s cut line, I thought that was what you was asking for. I can send you an engrave file also.


(Andrea Campanella) #11

No, this is ok, thanks :slight_smile:


(Andrea Campanella) #12

about the difference between Inkscape and Ai

From this post:

“I’m going to guess it’s because Inkscape assumes a resolution of 90 DPI, and Illustrator 72 DPI.”

"Actually you can change the dpi in inkscape.

Click File > Inkscape Preferences > Import/Export > change the dpi in the box there. I just tried it, and seems to fix the problem when copying and pasting into Illustrator - the image pasted was the same size in illustrator as in inkscape."


(Andrea Campanella) #13

Cracked. It’s the scaling.

I will explain how and why this is happening:

Screen resolution of laptops are being going up and up recently, especially for professional workstations, this is called HiDPI.

Inkscape, recently, changed the default DPI to HiDPI and because this changes the dynamic of how the screen is drawn and the density per pixel of the drawing they have to save it with the same DPI (90) otherwise you would lose information.

Adobe it’s like “What’s this s*hit I don’t care, I’m too busy working on Illustrator online.” so, they keep 72 DPI.

Trotec doesn’t even know about the issue because their R&D is more D then R. Jobcontrol doesn’t know what to do with 92 DPI so, it silently ignore anything and not showing the cut line (engraving line is raster, that one works) .

People have managed to cut recently with :

Old files. which are still 70 DPI so inkscape doesn’t change them.

Tricking Jobcontrol into see 2 lines (I suspect there is a bug where jobcontrol doesn’t check the DPI of the second set of line.) or changing the cut line in a way that actually forces a lower DPI (due to the lower resolution.)

I found this template for the trotec lasercutter and inkscape:

Apparently the problem is connected from the version of inkscape 0.92 and above.

I need to test this but I can possibly find a way to force the lower DPI.