Craft Robo Vinyl Cutter

Tried to get the little Craft Robo vinyl cutter to work when I was in the space earlier and ended up running out of time before I could do anything with it. I just need to cut some vinyl lettering for labels out with it.

From looking up videos online it needs some sort of guide sheet to adhere the vinyl onto, do we have any of these and if so, where might they be? If not could we / I order some for the space and find a place for them to live?

Secondly the drivers page found when googling didn’t exactly fill me with confidence, has anyone managed to get this thing working on a mac before, any advice would be most appreciated.

@peter_hellyer had is going on a Mac

@Ty_design has said it’s not working properly

Not had a chance to check it out

For cutting materials that don’t have a backing we have adhesive backing sheets… hanging on a nail in the wall beside electronics (where the vinyl cutters used to be)

The bigger vinyl cutter was set up and working perfectly, but it looks like someone maybe have tried to improve it and messed up the tensions on the rollers…only used that one via Linus, cut Inkscape with Inkcut is meant to work on a Mac, I believe

Needs cameo studio to work. No driver on a Mac as it’s effectively a serial device

Aha! Maybe I just didn’t realise that’s what it was, I might just need a hand in person when such things are possible. Is there the film for transferring it over too?

If it really is not something that works with a Mac I might have to pull out the bugger cutter and get it working. I ruefully see I had a message about it two years ago and never actually got around to it. Better late than never I guess?

1 Like

There were several rolls of transfer tape knocking around…may be with the cutters

Aha! Excellent, thanks for all the help. I’ll have another crack at it next week.

I’ll try and document this all and put it up on a page in the tools category to make it easier for the next person who wants to use it, if I can get it to work.

I’ve got a feeling I started a page for it ages ago… I’ll have a rummage later

1 Like

Sorry, wrote like an idiot on the move

Works perfectly on a Mac, just needs this piece of crapware https://www.silhouetteamerica.com/software - and ‘just works’

Argh it’s an installer bundle crapware, not even regular terrible software!

It’s not great but it does work, we use these machines at work all the time, I donated the machine as I thought it would be useful, if folks don’t want it I am sure another space will.

Just having trouble setting it up, not saying we should get rid of it.

Are you actually getting it to cut yet?

No, got lost in the software and didn’t have time to really expend enough attention on it after working on my other project. I’ll have a proper crack at just that next time I’m in the space.